• Home
  • Knowledge
  • Hydra
  • What do I do if the error “GLIBCXX_3.4.11 not found” or ‘GLIBC_2.7 not found’ is produced?

What do I do if the error “GLIBCXX_3.4.11 not found” or ‘GLIBC_2.7 not found’ is produced?

If the following error is generated when you are compiling applications on Linux OS with Lycia, you should upgrade the current version of your operating system to eliminate the problem.
The error text may look like of of the following:
/opt/Querix/Lycia/bin/qfgl: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11′ not found (required by /opt/Querix/Lycia/lib/libdbconfig.so.5)
/opt/Querix/Lycia/bin/qfgl: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11′ not found (required by /opt/Querix/Lycia/lib/libio.so.5)
Library load error: /lib/libc.so.6: version `GLIBC_2.7′ not found (required by /home/querix/Common/lib/libxml2.so.2)

Click the link below to see
all KB articles by product.